Extension not loading on cloud.microsoft domains after an update to the Microsoft Edge Browser (version 150)

Incident Report for WalkMe US Status

Resolved

Per https://github.com/microsoft/MicrosoftEdge-Extensions/issues/644#issuecomment-4933908795 "Currently, extensions are not designed to work with Copilot. At this time, the list of sites where Microsoft extensions are blocked includes Copilot, Edge:// pages, and EAS*"
From our research, it seems that the affected domains are only the following 2 domains:
https://m365.cloud.microsoft/
https://copilot.com/
Posted Jul 12, 2026 - 19:15 UTC

Update

We are continuing to investigate this issue.
Posted Jul 10, 2026 - 19:25 UTC

Update

We are continuing to investigate this issue.
Posted Jul 10, 2026 - 19:13 UTC

Update

Microsoft Edge v150 has implemented a blocking policy that prevents all extensions from running on cloud.microsoft domains. This is due to changes Microsoft made to their browser, and it is impacting all extension users including WalkMe. We have escalated to Microsoft and are advocating for a fix as soon as possible.
Posted Jul 10, 2026 - 18:56 UTC

Investigating

We are currently investigating this issue.
Posted Jul 10, 2026 - 17:42 UTC
This incident affected: End User Experience (Browser Extensions).