WalkMe US Editor and Admin Services are currently inaccessible

Incident Report for WalkMe US Status

Resolved

This incident has been resolved.
Posted Jun 30, 2023 - 16:34 UTC

Investigating

We are currently investigating an issue impacting the US Data center for the WalkMe Editor, console.walkme.com, admin.walkme.com, and insights.walkme.com.

Our team is working hard to resolve the issue as soon as possible.
Posted Jun 30, 2023 - 16:20 UTC
This incident affected: Content Platform (Designer (Editor), DAP Console) and Admin Space.