Branding page for Workstation on Console is down
Incident Report for WalkMe US Status
Resolved
This incident has been resolved.
Posted Sep 28, 2024 - 13:42 UTC
Update
We are continuing to investigate this issue.
Posted Sep 28, 2024 - 13:34 UTC
Update
We are continuing to investigate this issue.
Posted Sep 28, 2024 - 13:34 UTC
Investigating
We are currently investigating this issue.
Posted Sep 27, 2024 - 20:22 UTC
This incident affected: Content Platform (DAP Console).